Donar $20 Donar $50 Donar $100 Donar mensualmente
 


Enviar respuesta 
 
Calificación:
  • 0 votos - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Buscar en el tema
Info II (Electrónica) - Problemas Con la Uart1 (LPC1769)
Autor Mensaje
tomy1995 Sin conexión
Empleado del buffet
Cursando 3er Año Ing. Electro...
*

Ing. Electrónica
Facultad Regional Buenos Aires

Mensajes: 6
Agradecimientos dados: 0
Agradecimientos: 3 en 2 posts
Registro en: Sep 2015
Mensaje: #1
Info II (Electrónica) - Problemas Con la Uart1 (LPC1769) Dudas y recomendaciones Informática II (Electrónica)
Hola a todos, estoy trabajando en un proyecto final que consiste en transmitir datos de un sensor a traves de la UART1 del lpc. el mayor inconveniente es que la misma transmite de forma inestable perdiendose varios segmentos del mensaje en el camino, como se muestra en la siguiente imagen. Adjunto el codigo que consiste en enviar un "*Hola Mundo*" y el resultado en pantalla del mismo. Alguien sabe una forma de poder solucionar esto? Gracias!


Salida Putty del puerto COM:
odM o*ouMlo*nual*dn aH*dM oHodM o*oualo*nual*dn aHodM oHouMlo*ouMlo*nual*dn aHodM oHouMlo*oual**n aH*dn ▒*dn ▒*dn ▒*dn ▒*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*ouMlo*nual*dn aHodM o*ouMlo*oual**n aH*dn oHodMlo*


Archivo(s) adjuntos
.zip  tptest.zip (Tamaño: 236,62 KB / Descargas: 5)
28-11-2017 21:58
Encuentra todos sus mensajes Agregar agradecimiento Cita este mensaje en tu respuesta
luchovl2 Sin conexión
Presidente del CEIT
Dígame, Ingeniero.
********

Ing. Electrónica
Facultad Regional Buenos Aires

Mensajes: 1.014
Agradecimientos dados: 19
Agradecimientos: 253 en 230 posts
Registro en: May 2009
Mensaje: #2
RE: Info II (Electrónica) - Problemas Con la Uart1 (LPC1769)
Hola tomy. Pinta problema de baudrate. Podés probar usar el debug del IDE. Unís Tx con Rx e imprimís en la consola del IDE con printf. ¿Se entiende?
De esa forma te deshacés de la comunicación con la PC. Y podés saber si los datos salen y entran bien.

¿Conocés el grupo de facebook de electrónica? Si querés metete. Ahí te va a responder más gente probablemente.
29-11-2017 15:02
Encuentra todos sus mensajes Agregar agradecimiento Cita este mensaje en tu respuesta
Buscar en el tema
Enviar respuesta 




Usuario(s) navegando en este tema: 1 invitado(s)



    This forum uses Lukasz Tkacz MyBB addons.