Donar $20 Donar $50 Donar $100 Donar mensualmente
 


Enviar respuesta 
 
Calificación:
  • 1 votos - 4 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Buscar en el tema
Segundo - Parcial de arquitectura de computadores
Autor Mensaje
JAHVEM13 Sin conexión
Empleado del buffet
Sin estado :(
*

Ing. en Sistemas
Otra

Mensajes: 3
Agradecimientos dados: 1
Agradecimientos: 2 en 1 posts
Registro en: Jun 2012
Google+
Mensaje: #1
Segundo - Parcial de arquitectura de computadores Parciales Arquitectura de Computadoras
--Espero poder contribuir en algo --

1. (30%) Escribir el código en lenguaje ensamblador para el siguiente pseudocódigo:

Variables
Entero i, n, j, mínimo
Real lista, X
Leer n
Para i = 1 hasta n
Leer lista[i]
Fin para
para i = 1 hasta n-1
mínimo = i;
para j = i+1 hasta n
si lista[j] < lista[mínimo] entonces
mínimo = j
fin si
fin para
X = lista[i]
lista[i] = lista[mínimo]
lista[mínimo] = X
fin para
Escribir “Lista ordenada”
Para i = 1 hasta n
Escribir lista[i]
Fin para

2. (40%) Elaborar los pseudocódigos que representa los siguientes códigos en lenguaje ensamblador, explicar que hacen y cuál es el resultado obtenido tras la ejecución de cada uno.

A)
INCLUDE Irvine32.inc
.data
array byte 10, 5, 3, 6, 9

.code
main PROC
mov ecx, 5
mov esi, 0
mov eax, 0
do:
add eax, array[esi]
call WriteInt
add esi, 1
loop do

B)
INCLUDE Irvine32.inc
.data
EnterX db "Enter X: ", 0
EnterY db "Enter Y: ", 0
Result db "Result: ", 0
.code
main PROC
mov edx, OFFSET EnterX
call WriteString
call ReadInt
mov eBx, eAx
mov edx, OFFSET EnterY
call WriteString
call ReadInt
add eAx, eBx
mov edx, OFFSET Result
call WriteString
call WriteInt
exit
main ENDP
END main

3. (10%) ¿Qué es una interrupción, cuales son los tipos de interrupciones y cuál es el proceso seguido por el sistema cuando recibe una interrupción?
4. (10%) Que características del sistema quedan determinadas por la cantidad de líneas en el bus de direcciones y en el bus de datos, explique y de un ejemplo para cada uno de los casos.
5. (10%) ¿Cuales son los tipos de interfaz de comunicaciones?, explique las propiedades y características de cada una de estas.
07-06-2012 00:26
Encuentra todos sus mensajes Agregar agradecimiento Cita este mensaje en tu respuesta
[-] JAHVEM13 recibio 2 Gracias por este post
gonnza (08-06-2012), Agusss95 (30-10-2013)
Buscar en el tema
Enviar respuesta 




Usuario(s) navegando en este tema: 1 invitado(s)



    This forum uses Lukasz Tkacz MyBB addons.